re = /^
(?#Block)
(?<block>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
(?:__
(?#Element)
(?<element>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
(?:--
(?#Modifier)
(?<modifier>(?:[a-z0-9]+)(?:-[a-z0-9]+)*)
)?
$/mx
str = 'block__element--modifier'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end