re = /[bB][sS][oO][dD]|[Bb]lue\s?screen/m
str = 'blue screen
Blue screen
BSOD
bsod
bluescreen
Bluescreen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end