#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[bB][sS][oO][dD]|[Bb]lue\s?screen"
Local $sString = "blue screen" & @CRLF & _
"Blue screen" & @CRLF & _
"BSOD" & @CRLF & _
"bsod" & @CRLF & _
"bluescreen" & @CRLF & _
"Bluescreen"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")