$re = '/[bB][sS][oO][dD]|[Bb]lue\s?screen/m';
$str = 'blue screen
Blue screen
BSOD
bsod
bluescreen
Bluescreen';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);