import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[bB][sS][oO][dD]|[Bb]lue\\s?screen";
final String string = "blue screen\n"
+ "Blue screen\n"
+ "BSOD\n"
+ "bsod\n"
+ "bluescreen\n"
+ "Bluescreen";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}