package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[bB][sS][oO][dD]|[Bb]lue\s?screen`)
var str = `blue screen
Blue screen
BSOD
bsod
bluescreen
Bluescreen`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}