using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[bB][sS][oO][dD]|[Bb]lue\s?screen";
string input = @"blue screen
Blue screen
BSOD
bsod
bluescreen
Bluescreen";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}