import Foundation
let pattern = #"(.*)(array\()([a-z=>'_ ]*)(\))(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #">columns(array('f_motivo' => new Expression("m.no_motivo"), 'f_descricao' => new Expression("('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))"), array('dt_order' => 'dt_inativacao')))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1[$3]$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)