package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(array\()([a-z=>'_ ]*)(\))(.*)`)
var str = `>columns(array('f_motivo' => new Expression("m.no_motivo"), 'f_descricao' => new Expression("('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))"), array('dt_order' => 'dt_inativacao')))`
var substitution = "$1[$3]$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}