# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(array\()([a-z=>'_ ]*)(\))(.*)/$1[$3]$5/g;t' <<< ">columns(array('f_motivo' => new Expression(\"m.no_motivo\"), 'f_descricao' => new Expression(\"('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))\"), array('dt_order' => 'dt_inativacao')))"