const regex = /(.*)(array\()([a-z=>'_ ]*)(\))(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(array\\()([a-z=>\'_ ]*)(\\))(.*)', 'g')
const str = `>columns(array('f_motivo' => new Expression("m.no_motivo"), 'f_descricao' => new Expression("('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))"), array('dt_order' => 'dt_inativacao')))`;
const subst = `$1[$3]$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);