using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(array\()([a-z=>'_ ]*)(\))(.*)";
string substitution = @"$1[$3]$5";
string input = @">columns(array('f_motivo' => new Expression(""m.no_motivo""), 'f_descricao' => new Expression(""('Data: ' || to_char(fi.dt_inativacao, 'DD/MM/YYYY') || '. Descrição: ' || (case when fi.ds_motivo is null then ' - ' else fi.ds_motivo end))""), array('dt_order' => 'dt_inativacao')))";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}