re = /(\d{1})[-](\d{3})[-](\d{3})[-](\d{4})/m
str = '2124567890
212-456-7890
(212)456-7890
(212)-456-7890
212.456.7890
212 456 7890
+12124567890
+12124567890
+1 212.456.7890
+212-456-7890
1-212-456-7890
1-21-345-7890
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result