package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1})[-](\d{3})[-](\d{3})[-](\d{4})`)
var str = `2124567890
212-456-7890
(212)456-7890
(212)-456-7890
212.456.7890
212 456 7890
+12124567890
+12124567890
+1 212.456.7890
+212-456-7890
1-212-456-7890
1-21-345-7890
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}