import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1})[-](\\d{3})[-](\\d{3})[-](\\d{4})";
final String string = "2124567890\n"
+ "212-456-7890\n"
+ "(212)456-7890\n"
+ "(212)-456-7890\n"
+ "212.456.7890\n"
+ "212 456 7890\n"
+ "+12124567890\n"
+ "+12124567890\n"
+ "+1 212.456.7890\n"
+ "+212-456-7890\n"
+ "1-212-456-7890\n"
+ "1-21-345-7890\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}