#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{1})[-](\d{3})[-](\d{3})[-](\d{4})"
Local $sString = "2124567890" & @CRLF & _
"212-456-7890" & @CRLF & _
"(212)456-7890" & @CRLF & _
"(212)-456-7890" & @CRLF & _
"212.456.7890" & @CRLF & _
"212 456 7890" & @CRLF & _
"+12124567890" & @CRLF & _
"+12124567890" & @CRLF & _
"+1 212.456.7890" & @CRLF & _
"+212-456-7890" & @CRLF & _
"1-212-456-7890" & @CRLF & _
"1-21-345-7890" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)