// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ocp)(([A-Z]+|[A-Z][a-z0-9]+)(\d|[A-Z][a-z0-9]+)*)(Type|Enum|Struct|Func)(Ptr)?").unwrap();
let string = "ocpCSRSolverContextEnumPtr
ocpSolverContextFunc
ocpSolverFloat64Func
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}