import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ocp)(([A-Z]+|[A-Z][a-z0-9]+)(\\d|[A-Z][a-z0-9]+)*)(Type|Enum|Struct|Func)(Ptr)?";
final String string = "ocpCSRSolverContextEnumPtr\n"
+ "ocpSolverContextFunc\n"
+ "ocpSolverFloat64Func\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}