re = /(ocp)(([A-Z]+|[A-Z][a-z0-9]+)(\d|[A-Z][a-z0-9]+)*)(Type|Enum|Struct|Func)(Ptr)?/m
str = 'ocpCSRSolverContextEnumPtr
ocpSolverContextFunc
ocpSolverFloat64Func
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end