const regex = new RegExp('(ocp)(([A-Z]+|[A-Z][a-z0-9]+)(\\d|[A-Z][a-z0-9]+)*)(Type|Enum|Struct|Func)(Ptr)?', 'gm')
const str = `ocpCSRSolverContextEnumPtr
ocpSolverContextFunc
ocpSolverFloat64Func
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}