package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ocp)(([A-Z]+|[A-Z][a-z0-9]+)(\d|[A-Z][a-z0-9]+)*)(Type|Enum|Struct|Func)(Ptr)?`)
var str = `ocpCSRSolverContextEnumPtr
ocpSolverContextFunc
ocpSolverFloat64Func
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}