$re = '/(ocp)(([A-Z]+|[A-Z][a-z0-9]+)(\d|[A-Z][a-z0-9]+)*)(Type|Enum|Struct|Func)(Ptr)?/m';
$str = 'ocpCSRSolverContextEnumPtr
ocpSolverContextFunc
ocpSolverFloat64Func
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);