import Foundation
let pattern = #"class="[^"]*(?<="|\s)col-xs-9(?="|\s[^>]*)">(?<name>[^<]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<div class="top_seller_name col-xs-9">
Yusuf
<div class="sprite_view_icn_whatsapp top_seller_whatsapp_sprite">
<div class="top_seller_whatsapp">WhatsApp Preferred</div>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)