$re = '@class="[^"]*(?<="|\s)col-xs-9(?="|\s[^>]*)">(?<name>[^<]*)@ims';
$str = '<div class="top_seller_name col-xs-9">
Yusuf
<div class="sprite_view_icn_whatsapp top_seller_whatsapp_sprite">
<div class="top_seller_whatsapp">WhatsApp Preferred</div>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);