const regex = new RegExp('class="[^"]*(?<="|\\s)col-xs-9(?="|\\s[^>]*)">(?<name>[^<]*)', 'gims')
const str = `<div class="top_seller_name col-xs-9">
Yusuf
<div class="sprite_view_icn_whatsapp top_seller_whatsapp_sprite">
<div class="top_seller_whatsapp">WhatsApp Preferred</div>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}