use strict;
my $str = '<div class="top_seller_name col-xs-9">
Yusuf
<div class="sprite_view_icn_whatsapp top_seller_whatsapp_sprite">
<div class="top_seller_whatsapp">WhatsApp Preferred</div>
</div>
</div>';
my $regex = qr@class="[^"]*(?<="|\s)col-xs-9(?="|\s[^>]*)">(?<name>[^<]*)@imsp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}