re = /class="[^"]*(?<="|\s)col-xs-9(?="|\s[^>]*)">(?<name>[^<]*)/im
str = '<div class="top_seller_name col-xs-9">
Yusuf
<div class="sprite_view_icn_whatsapp top_seller_whatsapp_sprite">
<div class="top_seller_whatsapp">WhatsApp Preferred</div>
</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end