re = /[ ]{2,}/mi
str = 'TEXTO texto
texto texto texto
texto texto t'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result