# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ ]{2,}/ /mgi;t' <<< "TEXTO texto
texto texto texto
texto texto t"