$re = '/[ ]{2,}/mi';
$str = 'TEXTO texto
texto texto texto
texto texto t';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;