#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)[ ]{2,}"
Local $sString = "TEXTO texto" & @CRLF & _
"texto texto texto" & @CRLF & _
"texto texto t"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)