use strict;
my $str = 'TEXTO texto
texto texto texto
texto texto t';
my $regex = qr/[ ]{2,}/mip;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";