const regex = /[ ]{2,}/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ ]{2,}', 'mgi')
const str = `TEXTO texto
texto texto texto
texto texto t`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);