re = /[^>]*class="[^"]*(?<="|\s)dd-price(?="|\s)[^"]*"[^<]*.*?content="(\d+)"/mi
str = '<dd class="dd-price" itemprop="offers" itemscope="" itemtype="http://schema.org/Offer"> <meta itemprop="priceCurrency" content="MYR"><meta itemprop="price" content="110"> RM 110 </dd>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end