const regex = new RegExp('[^>]*class="[^"]*(?<="|\\s)dd-price(?="|\\s)[^"]*"[^<]*.*?content="(\\d+)"', 'gmis')
const str = `<dd class="dd-price" itemprop="offers" itemscope="" itemtype="http://schema.org/Offer"> <meta itemprop="priceCurrency" content="MYR"><meta itemprop="price" content="110"> RM 110 </dd>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}