using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^>]*class=""[^""]*(?<=""|\s)dd-price(?=""|\s)[^""]*""[^<]*.*?content=""(\d+)""";
string input = @"<dd class=""dd-price"" itemprop=""offers"" itemscope="" itemtype=""http://schema.org/Offer""> <meta itemprop=""priceCurrency"" content=""MYR""><meta itemprop=""price"" content=""110""> RM 110 </dd>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}