import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^>]*class=\"[^\"]*(?<=\"|\\s)dd-price(?=\"|\\s)[^\"]*\"[^<]*.*?content=\"(\\d+)\"";
final String string = "<dd class=\"dd-price\" itemprop=\"offers\" itemscope=\"\" itemtype=\"http://schema.org/Offer\"> <meta itemprop=\"priceCurrency\" content=\"MYR\"><meta itemprop=\"price\" content=\"110\"> RM 110 </dd>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}