$re = '@[^>]*class="[^"]*(?<="|\s)dd-price(?="|\s)[^"]*"[^<]*.*?content="(\d+)"@mis';
$str = '<dd class="dd-price" itemprop="offers" itemscope="" itemtype="http://schema.org/Offer"> <meta itemprop="priceCurrency" content="MYR"><meta itemprop="price" content="110"> RM 110 </dd>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);