use strict;
my $str = '<dd class="dd-price" itemprop="offers" itemscope="" itemtype="http://schema.org/Offer"> <meta itemprop="priceCurrency" content="MYR"><meta itemprop="price" content="110"> RM 110 </dd>';
my $regex = qr@[^>]*class="[^"]*(?<="|\s)dd-price(?="|\s)[^"]*"[^<]*.*?content="(\d+)"@misp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}