import Foundation
let pattern = #"(\d+).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
node
1077_shift_factor_avg
1694_shift_factor_avg
1922_shift_factor_avg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"cnstrnt_\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)