$re = '/(\d+).+/m';
$str = 'node
1077_shift_factor_avg
1694_shift_factor_avg
1922_shift_factor_avg
';
$subst = "cnstrnt_\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;