#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+).+"
Local $sString = "node" & @CRLF & _
"1077_shift_factor_avg" & @CRLF & _
"1694_shift_factor_avg" & @CRLF & _
"1922_shift_factor_avg" & @CRLF & _
""
Local $sSubst = "cnstrnt_\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)