using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+).+";
string substitution = @"cnstrnt_\1";
string input = @"node
1077_shift_factor_avg
1694_shift_factor_avg
1922_shift_factor_avg
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}