const regex = new RegExp('(\\d+).+', 'gm')
const str = `node
1077_shift_factor_avg
1694_shift_factor_avg
1922_shift_factor_avg
`;
const subst = `cnstrnt_\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);