import Foundation
let pattern = #"^(\\|[a-zA-Z]:)(\\\w[\w-.]*){2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\\se8p10000683
\\se8p10000683\appdata\aps\apsinstaller\done\abru0103-497-0018855-oav-cc-999-00zfz7g
\\se8p10000683\appdata\aps\apsinstaller\done\00a.bd.con
\\se8p10000683\appdata\aps\..\..\inetpub\ftproot
\\se8p10000683\appdata\aps\..\inetpub\ftproot
\\se8p10000683\appdata\aps\%2e
c:\boot.ini
c:\windows\notepad.exe
p:\appdata\aps\apsinstaller\done\abru0103-497-0018855-oav-cc-999-00zfz7g
p:\appdata\aps\coucou.pdf
\\se8p10000683\appdata\aps\%2e.pdf
\\se8p10000683\appdata\aps\test.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)