const regex = /^(\\|[a-zA-Z]:)(\\\w[\w-.]*){2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\\|[a-zA-Z]:)(\\\\\\w[\\w-.]*){2,}', 'gm')
const str = `\\\\se8p10000683
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\00a.bd.con
\\\\se8p10000683\\appdata\\aps\\..\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\%2e
c:\\boot.ini
c:\\windows\\notepad.exe
p:\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
p:\\appdata\\aps\\coucou.pdf
\\\\se8p10000683\\appdata\\aps\\%2e.pdf
\\\\se8p10000683\\appdata\\aps\\test.pdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}