use strict;
my $str = '\\\\se8p10000683
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\00a.bd.con
\\\\se8p10000683\\appdata\\aps\\..\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\%2e
c:\\boot.ini
c:\\windows\\notepad.exe
p:\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
p:\\appdata\\aps\\coucou.pdf
\\\\se8p10000683\\appdata\\aps\\%2e.pdf
\\\\se8p10000683\\appdata\\aps\\test.pdf
';
my $regex = qr/^(\\|[a-zA-Z]:)(\\\w[\w-.]*){2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}