// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\\|[a-zA-Z]:)(\\\w[\w-.]*){2,}").unwrap();
let string = "\\\\se8p10000683
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\00a.bd.con
\\\\se8p10000683\\appdata\\aps\\..\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\%2e
c:\\boot.ini
c:\\windows\\notepad.exe
p:\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
p:\\appdata\\aps\\coucou.pdf
\\\\se8p10000683\\appdata\\aps\\%2e.pdf
\\\\se8p10000683\\appdata\\aps\\test.pdf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}