$re = '/^(\\\\|[a-zA-Z]:)(\\\\\w[\w-.]*){2,}/m';
$str = '\\\\se8p10000683
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\00a.bd.con
\\\\se8p10000683\\appdata\\aps\\..\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\..\\inetpub\\ftproot
\\\\se8p10000683\\appdata\\aps\\%2e
c:\\boot.ini
c:\\windows\\notepad.exe
p:\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g
p:\\appdata\\aps\\coucou.pdf
\\\\se8p10000683\\appdata\\aps\\%2e.pdf
\\\\se8p10000683\\appdata\\aps\\test.pdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);