# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\\|[a-zA-Z]:)(\\\w[\w-.]*){2,}"
test_str = ("\\\\se8p10000683\n"
"\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g\n"
"\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\00a.bd.con\n"
"\\\\se8p10000683\\appdata\\aps\\..\\..\\inetpub\\ftproot\n"
"\\\\se8p10000683\\appdata\\aps\\..\\inetpub\\ftproot\n"
"\\\\se8p10000683\\appdata\\aps\\%2e\n"
"c:\\boot.ini\n"
"c:\\windows\\notepad.exe\n"
"p:\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g\n"
"p:\\appdata\\aps\\coucou.pdf\n"
"\\\\se8p10000683\\appdata\\aps\\%2e.pdf\n"
"\\\\se8p10000683\\appdata\\aps\\test.pdf\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.